<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>IE browser settings</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>Logging on</td>
<td>11</td>
</tr>
<tr>
<td>3</td>
<td>Exploring the Web Publishing Environment</td>
<td>11</td>
</tr>
<tr>
<td>4</td>
<td>Text editing</td>
<td>14</td>
</tr>
<tr>
<td>5</td>
<td>Inserting and uploading images</td>
<td>16</td>
</tr>
<tr>
<td>6</td>
<td>Uploading and downloading documents</td>
<td>19</td>
</tr>
<tr>
<td>7</td>
<td>Creating links</td>
<td>22</td>
</tr>
<tr>
<td>8</td>
<td>Inserting tables</td>
<td>24</td>
</tr>
<tr>
<td>9</td>
<td>Creating new pages</td>
<td>26</td>
</tr>
<tr>
<td>10</td>
<td>Changing page layout</td>
<td>27</td>
</tr>
<tr>
<td>11</td>
<td>Editing web page properties</td>
<td>28</td>
</tr>
<tr>
<td>12</td>
<td>Saving a web page</td>
<td>28</td>
</tr>
<tr>
<td>13</td>
<td>Page history</td>
<td>30</td>
</tr>
<tr>
<td>14</td>
<td>Modifying navigation</td>
<td>31</td>
</tr>
<tr>
<td>15</td>
<td>File naming convention</td>
<td>33</td>
</tr>
<tr>
<td>16</td>
<td>Creating Websites</td>
<td>33</td>
</tr>
<tr>
<td>17</td>
<td>Inserting a Web Part</td>
<td>38</td>
</tr>
<tr>
<td>18</td>
<td>Ad Rotator Web Part</td>
<td>41</td>
</tr>
<tr>
<td>19</td>
<td>Picture Gallery Slideshow Web Part</td>
<td>43</td>
</tr>
<tr>
<td>20</td>
<td>Survey</td>
<td>46</td>
</tr>
<tr>
<td>21</td>
<td>Calendar</td>
<td>48</td>
</tr>
<tr>
<td>22</td>
<td>Site Permissions</td>
<td>57</td>
</tr>
<tr>
<td>23</td>
<td>Anonymous Access</td>
<td>68</td>
</tr>
</tbody>
</table>
1. IE Settings

Internet Explorer (IE) should have the correct settings for SharePoint editing tools to work properly.

**Step 1: Adding your SharePoint site to Local Intranet zone**

- Open your SharePoint site in IE browser
- Go to Tools menu and select Internet Options
- Select Local Intranet and click on Sites

![Internet Options](image)

- Click on Advanced button in local Intranet dialog box

![Local intranet](image)

Your site URL (e.g. http://www.rscdd.edu) should appear under “Add this website to the zone:”
• Click Add

• If your site has been already added to Trusted Sites zone, you will receive the prompt below. Click YES to move your site to the Local Intranet zone.
Your site is now added to **Local Intranet** zone

Click on **Close**

- Click **OK** to exit **Local Intranet** dialog box and go back to **Internet Options**

**Step 2: Deselect** *Enable native XMLHTTP Support*

- In **Internet Options**, select **Advanced**.
• Look for the option *Enable native XMLHTTP Support*, and uncheck it.

**Step 3:** Custom level security settings
Select Security tab, select Local Intranet and click on Custom Level...

Security Settings:

- Under ActiveX controls and plug-ins, enable the following settings:
  - Allow previously unused ActiveX controls to run without prompt
• Allow scriptlets

Under *Scripting*, enable the following settings:

• Allow status bar updates via script
- Allow websites to prompt for information using scripted windows

User Authentication

Make sure “Prompt for user name and password” is checked so you are not automatically logged on to local intranet zone.
Click OK to exit Internet Options

**Step 4: Adding your site to compatibility view**

- Go to Tools > Compatibility View Settings
- Your site (e.g. rsccd.edu) appears under “Add this website:”
• Click Add
• Check “Display all websites in Compatibility View”

![Compatibility View Settings](image)

**Step 5: Applying the new configuration**

1. Clear Browsing History
2. Exit IE browser
3. Reopen IE browser

**2. Logging on:**

Log on to rsccd.edu:

- Open RSCCD web site (http://new.rsccd.edu/)
- Click on Faculty & Staff tab on the top navigation
- Click on SharePoint Sign In under General Information
- Enter your username and network password
Log on to sac.edu:

- Open SAC web site (http://www.sac.edu/)
- Click on Faculty & Staff tab on the top navigation
- Click on SharePoint Sign In link on the left navigation
- Enter your username and network password

Log on to sccollege.edu:

- Open SCC web site (http://www.sccollege.edu/)
- Click on Faculty & Staff link on the left navigation of the home page
- Click on the Sign In link at the bottom right of the top banner
- Enter your username and network password

**Note:** After logging on, you are taken to the main site home page. Please access the sub-site you have author permission. The editing tools will only appear to you in your site.

---

### 3. Exploring the Web Publishing Environment

**Site Actions**

The Site Actions menu only appears in the site you have author permission.

- Click on the Site Actions menu.
- Click on View All Site Content.
- You are taken to the All Site Content area, which is the main repository for your site content. You will see three SharePoint Document Libraries:
  - **Documents** - This is where you will upload and store documents (i.e. existing files) that you link to on web pages.
  - **Images** - This is where you upload and store pictures and graphics that you place on web pages.
  - **Pages** - This is where web pages are stored. Notice there is an existing page already in your Pages Library named "default.aspx". This is your home page for the site and is created automatically when a site is created in SharePoint.
Whenever you delete an item stored in a library (i.e. a document, image, or page) the item is sent to your site's recycle bin where it stays for 60 days (unless this value is changed by your SharePoint Administrator). Use your Recycle Bin to restore an item to the location where it was deleted from.

Note: Your site's Recycle Bin is a completely separate recycle bin that appears on your Windows desktop.
Context sensitive ribbon

The ribbon is a dynamic toolbar that appears across the top of each page. It displays different tools, controls and commands corresponding to the selected tab.

Under Site Actions, select Show Ribbon and then click on each tab on the ribbon to view related controls.

Text editing tools:

Page tools:

Insert:
4. Text Editing

- Open the Pages library
- Open the page you want to edit
- Click on the Page tab in the ribbon toolbar

Review the options available on the Page ribbon. This is one of many ribbon toolbars that are included in Exploring Web Publishing Environment.

*Note: some icons are “grayed out” which means you do not have access to the option.*

Click on the **Edit quick access button** (or click on the Edit option under Page tab).

The ribbon now displays the text editing tools.

**Copying/pasting text**

- Copy text content from current site or from a Word document
- Place your cursor inside the Page Content area
- Select Paste > Paste plaintext
  
  *(Paste plaintext option helps remove inline styles from the original document.)*
Text formatting

The standard body text style is applied to the page content by default. You don't need to change it. To be compliant to web accessibility, you should structure your page with headings. Screen reader users will navigate the page content through headings.

H1 is the page title, already applied when you create a new page. H2, H3, H4... are used to structure your page content.

To keep the text formatting consistent across the whole site, please use the Markup Styles to format your text. It is not recommended that you create your own bold and big text with different colors to replace the headings.

5. Inserting and Uploading Images

Images used for your web pages need to be upload to the Images Library. You cannot copy an image from a web page or a document and paste it into your page content.

- Place your cursor inside the Page Content area and then click on the Insert tab on the ribbon.
• Click on the arrow under the **Picture** icon, and select **From Computer**.

![Insert](image1.png)

• In the **Select Picture** dialog window, click on the **Browse** button. Browse to the location of your image file, click on the file name and select the **Open** button.

• On the **Select Picture** dialog window, ensure that **Images** is selected in the "**Upload to**" field. This will ensure that your image file is uploaded into your **Images Library**. Click on the **OK** button to upload and save the image.

![Select Picture](image2.png)

The image properties dialog window will open. Image properties are optional. If you don't need any change, click **Cancel** to close the window.

With the image is selected, the **Picture Tools** are displayed on the ribbon. Select its position, add Alt Text and edit other properties if needed.

The image is now appropriately placed on the page and contains alt text as required for accessibility compliance (Read more about alt text below this part).
**Image placement requirements:**

- You must use one of the 3 following file formats:
  - JPG - for photos
  - GIF - for graphics with solid colors
  - PNG - graphics with solid colors or with a transparent background (e.g. logo, buttons, saved from vector graphics)

- Your image must be sized
  Avoid using big images for page content because this will slow down the page loading time. Less than 100KB file size is more preferable.
If you use Photoshop or another image editor software, select the “Save for Web…” option to optimize your images for web use.

- Images must be uploaded to Images Library
- Insert image to the page
- Position as needed (float left/right)
- Add Alt text

**More About Alt Text...**

To comply with Web accessibility standards when placing images and graphics on pages, always remember to alternative text “alt text” for every image placed on a web page.
Here are some general guidelines on the use of alt text:

- If the image conveys information, or conveys text, then the alt text should convey the same information.
• If the purpose of the image/graphic is to provide "eye candy" (i.e. visually setting a mood) then alt text should be blank.

• If the image is redundant or conveys no information, the alt text should be blank.

• If the image is an active link, the alt text should be the function of the image (i.e. what the target of the link is).

• In all instances of Alt Text, avoid entering “picture of...” or “image of...” or “link to...” etc. as screen reading software already informs the user of this when they encounter an image or link.

• When images of tables or graphs are placed on page, in addition to alt text, a complete description of the information contained on the table or graph should follow the image.

**Uploading images into the Images Library**

Upload your images before using them for your web pages.

• Go to Site Actions, select View All Site Content
• Open the Images Library

![Image of Document Libraries]

• Click on Add new item

![Image of Add new item]

• Click on the Browse button to browse to a single image file to upload, or select “Upload Multiple Files...” to upload multiple files in one time

![Image of File Upload]

*Note:* Currently, only Internet Explorer (IE) browser supports multiple files uploading.

**Creating image folders**

Images of the same category should be organized in a separate folder created under the Images Library.
6. Uploading and Downloading Documents

Before linking to your web pages, documents should be uploaded to the Documents Library.

PDF file format is recommended for documents used for the web.

**Uploading Documents to the Documents Library**

- Go to Site Actions, select View All Site Content and open the Documents Library.

- Browse to a single image file to upload, or select “Upload Multiple Files...” to upload multiple files in one time. Currently, only Internet Explorer (IE) browser supports multiple files uploading.
Creating Document Folders

Documents of the same category should be organized in a separate folder created under the Documents Library.

- Open the Documents Library
- Click on Documents under Library Tools tab
- Select New Folder
- Name the new folder
- Open the new folder
- Click on “Add document” link to upload documents

Downloading Documents from a Documents Library

To download each document from the Documents Library, click on the arrow on the right of the document file name and select “Download a Copy” from the dropdown menu.

To download multiple documents,
• open the Documents Library or any subfolder you want to download documents from it

• click on **Open with Explorer** link on the ribbon

• A window explorer will pop up for you to copy the document files and paste into your local machine

7. Creating Links

In the page content you could create 3 types of links: link to another web page, link to a document and external link.

**Link to another web page:**

• Highlight the text you want to make a link

• Select the **Insert** tab

• Select **Link** and then select **From SharePoint**
• In the **Select an Asset** dialog box, click on the **Pages** library link on the left bar to display all web pages
• Select the page you want to link and click OK

**Link to a document:**

• Highlight the text you want to make a link
• Select the **Insert** tab
• Select **Link** and then select **From SharePoint**
• In the **Select an Asset** dialog box, click on the **Documents** library link on the left bar to display all documents
• Select the document you want to link and click OK

**Note:** link to a document should open a new window.

Check “**Open in new tab**” under **Link Tools /Format** on the ribbon.

From the **Select an Asset** dialog box, you can upload a new file to link to.
Select the appropriate documents library (**Documents** or **Pages**) on the left pane to open it, click on the “Upload” link, and upload your file to that specific library. Then, you can create a link to the newly uploaded file.

**Link to an external web page:**

• Highlight the text you want to make a link
• Select the **Insert** tab
• Select **Link** and then select **From Address**
• In the Insert Hyperlink dialog box, enter the URL of the web site or web page you want to link to.

Note: External web page should open in a new window.
Check “Open in new tab” under Link Tools /Format on the ribbon.

Inserting a link to an image

• Select the image you want to insert a hyperlink
• If you select From SharePoint, the process is the same as creating a text link above
• If you select From Address, enter the URL to the Address field
  Leave the “Text to display” field blank. (Note: External web page should open in a new window.)

Removing a link

Place cursor on the link and then click on “Remove Link” on the ribbon.

Note: Deleting an existing link in the URL field does not remove it completely. The link still remains, but pointing to the default page. To remove a link completely, click on “Remove Link” icon.
Changing the URL of an existing link

- Place cursor on the existing link and click **Select Link** icon
- Select a document or web page from SharePoint site
- For external link, enter URL to the Location(URL) field and check “Open in a New Tab”

8. Inserting Tables

- Click on the **Edit** tab
- Select **Insert** > **Table**
- Select the number of rows and columns

Table Tools

Table Layout:
Table Design:

Selecting a predefined table style.

The Clear tables are used to line up text blocks or graphics in columns and rows. They have no borders.
Options to display column and row headers:

Header Row and First column are checked by default.

9. Creating New Pages

- Click on Site Actions and select New Page

You can also create a new page in All Site Content by clicking on the Create link.

- Enter the new page name and click Create (View #14 - File naming convention)

You are redirected to the new page in edit page mode which means you can start to add content to the page.
In the **Title** field, edit the page title.  
*Note: Page Titles are different than page names: page titles appear on top of the web pages, they should contain spaces. Page names are file names, they should not contain spaces.*

The link to the newly created page is automatically placed on the current site navigation bar after you published it.

You could disable this feature in the **Navigation Settings** and add links manually to the current site navigation. There are pages you want to create links in the page content and don’t want them to automatically show on the left navigation. (View #13 - Modifying navigation / Current navigation)

---

### 10. Changing Page Layout

To change the page layout, you need to be in editing mode.

- Select **Edit** tab and then select **Page** tab
- Select a page layout from **Page Layout** dropdown

![Page Layout](image)

Each web site collection (RSCCD, SAC, SCC, Foundation...) has its own set of page layouts. If the default page layout does not suit your page content, you can change it to a more suitable one.

---

### 11. Editing Page Properties

You can change the file name, title, and others page elements for an existing web page by editing its properties.

To open the page properties, select **Edit Properties** under the **Page** tab.
12. Saving a Web Page

There are 3 options for saving and closing a web page:

1. **Save & Close**: Save changes to the page and exit edit mode
2. **Save and Keep Editing**: Save changes to the page and continue editing
3. **Stop Editing**: Exit edit mode on this page. You will be prompted to save or discard your changes.

When you open a web page in edit mode, it is checked out to you. The status bar shows that the page is "checked out and editable".

```
Status: Checked out and editable.
```

When a page is checked out to you, other permitted users cannot see your changes, and cannot edit that page until you check it in.
Check In options:

1. **Check In**: You check in the page which is currently checked out to you.

2. **Discard Check Out**: Check in this page, discarding any changes you have made to your checked out version.

While you are working on the update and save your page, your changes are not visible to the public. You need to publish your page for the update to be viewable by the public.

Select **Publish** tab and click **Publish**.

SharePoint creates a minor version of a page each time you check it in. And, a major version is created each time you publish a page. The current live page is the latest major version.

Major versions are always in whole numbers, such as 1.0, 2.0, and so on. Minor versions are denoted by decimals following a major version number, such as 1.1, 1.2, 1.3 and so on. Supposed the latest minor version is 4.3, when you publish the page the next major version will be 5.0.

**13 - Page History**

- Each web page has a version history.
• The number of major and minor versions can be set in Page Library Settings > Versioning Settings
• You can restore a previous version of a page.

To view Page History,

• Select the Page tab on the ribbon
• Select Page History
• On the Page History page, click on the Version History option.

To restore a previous version,

• Select Restore from the dropdown menu.

It is important to know how to access the version history for your page should you need to revert back to a previous version.
14. Modifying Navigation

- From the Site Actions, select Site Settings
- Under Look and Feel, select Navigation to open the Navigation Settings page.

You can do the following modifications:

- Show/hide global and current navigation links
- Sort links automatically or manually
- Move links up and down (links on the current navigation are set to be sorted manually)
- Edit links and headings
- Add/Delete links and headings

Note:

- The Edit and Delete options are not available for a link that is populated automatically on the current navigation when you create a new page, or new subsite.
- The Edit and Delete options are available for links that are manually added to the current navigation.

Current navigation:

Show subsites & Show Pages

- With the "Show Pages" option checked, a link to a new page is automatically added to the current navigation bar when you create it. The corresponding link will be automatically removed from the left navigation bar when you delete a page.
• With the Show Pages option unchecked, links are not populated automatically on the current navigation when you create new pages. Then, you have to add links manually using Add Link... in Navigation Editing and Sorting section. In this case, you should add a Home link to go back to the home page.

Show subsites option works the same way.

15. File Naming Convention

Avoid using spaces for subsite names and file names.

Spaces will be replaced by %20 and display an unfriendly URL:

http://www.sac.edu/Training/WebUser/Documents/Brief%20Course%20Lab%20Guide.pdf

Replace spaces with underscores (_), dashes (-) or use no-space compound word with camel case

Web pages:

http://www.sccollege.edu/Departments/Testing/Pages/CoursePrerequisiteClearance.aspx
http://www.sccollege.edu/Departments/Testing/Pages/Course-Prerequisite-Clearance.aspx
http://www.sccollege.edu/Departments/Testing/Pages/Course_Prerequisite_Clearance.aspx

Documents:

http://www.sac.edu/Training/WebUser/Documents/BriefCourseLabGuide.docx
http://www.sac.edu/Training/WebUser/Documents/Brief-Course-Lab-Guide.docx
http://www.sac.edu/Training/WebUser/Documents/Brief_Course_Lab_Guide.docx

Naming convention for website: no-space and camel case

Website: http://www.sccollege.edu/Departments/AcademicSenate/

16. Creating Websites

Each website created under a parent site is called a “subsite” or website.

• Select New Site from Site Actions
• Select Publishing Site
• Click on More Options

- In Create window, enter Site Title and URL (follow naming convention)

- Keep default permissions (*Use same permissions as parent site*)
  You can break parent permissions inheritance later if needed.

- Click Create
Go back to the parent site and select **Site Actions > View All Site Content**. The new site appears under **Sites and Workspaces**.

Each subsite

- possesses all the features of a parent site.
- can inherit its parent permissions or have its own.
- can show parent navigation links or only its own navigation.
- can be made public or private.
  
  When it is private, only permitted users have access.

**Pages Library Settings**

- Open the **Pages** library and select the **Page** tab on the ribbon
• Click on **Library Settings** on the right hand side of the ribbon

![Library Settings](image)

• Under **General Settings**, select **Versioning Settings** to open the **Pages Library Settings** page.

  ◦ **Content Approval** is disabled by default. The **No** option should be checked.
    Note: If your site is assigned to a contributor and needs the site owner's approval to publish a page, you can enable the content approval by checking **Yes**.

  ◦ **Document Version History**
    Set the number of major and minor versions you want to keep.

  ◦ **Required Check Out**
    Check **YES**
    - to prevent multiple people from making changes at the same time.
    - so team members can add a comment to keep track what has changed in each version.
    - to enable the "Discard Check Out" option, which allows you to discard the changes you have made to your checked out version.

    Note: You can override a page checked out page by another user, but this will override all the changes that user has made.
Deleting a website

A SharePoint site is deleted from inside itself.

- Open the website you want to delete
- Go to Site Settings
- Under Site Actions, click on Delete this site

Note: In SharePoint 2010, a deleted site is not permanently deleted. It is stored in the Site Collection Recycle Bin and can be restored by ITS web administrator.
When do you create a new subsite?

To group web pages of the same category, you should create a subsite, not a sub-folder under the Pages Library.

In SharePoint, newly created web pages cannot go to a folder. When you open a folder under the Pages Library and create a new web page, it is automatically placed at the same level of the default.aspx page, at root level of the Pages Library. It is not placed inside the folder.

A folder under the Pages Library can be used to store uploaded stand-alone web pages you want to link to your SharePoint Pages.

16. Inserting a Web Part

Web Parts are used to display contents that are not supported by the Page Content editor (SharePoint lists and libraries, JavaScript, form, video, external web page …)

In SharePoint 2010, you can insert a web part anywhere in the page content.

To insert a Web Part:

- Place the cursor at the location you want to add the Web Part
- Select Insert tab on the ribbon
- Click on Web Part
- Select a Web Part from a category and click on the Add button
To open the Web Part editor, select “Edit Web Part” from the edit dropdown menu on the right hand side.

Content Editor Web Part editor:
Note: select None for Chrome Type to hide the title bar and border of the Web Part frame.

Most commonly used Web Parts:

- Lists and Libraries Web Parts: Picture library, Calendar, Announcement, Survey
- Media and Content Web Parts:
  - Content Editor Web Part allows authors to type directly to the WebPart content area, or link to existing content by entering a hyperlink to a text file that contains HTML source code
  - Page Viewer Web Part displays another Web page on this Web page (e.g. display an HTML form or an external web page.)
  - Picture Library Slide Show displays a slideshow of images and photos from a picture library.
- SectorPoint Ad Rotator Web Part displays rotating images from an image library.
18. SectorPoint Ad Rotator Web Part

Images used for the Ad Rotator are stored in a picture library. However, you should store them in an Advertisement Library, not a Picture Library, because the Advertisement Library allows adding a hyperlink to each image if needed. There is no option for adding a hyperlink to an image in a Picture Library.

**Step 1 - Creating an Advertisement Library**

- Under Site Actions menu, select More Options
  (another way: go to All Site Content and click on Create)
- In the Create window, select Advertisement Library and name it

[Image: Advertisement Library]

- Upload images to the advertisement library
- Double click on each image to open the image properties window
- Edit the image properties and add URL if needed.

**Step 2 - Adding an Ad Rotator Web Part to a web page**

- Place your cursor at the location you want to add the Ad Rotator Web Part
- Select Insert tab
- Select Web Part > SectorPoint > Ad Rotator Web Part

[Image: Adding Ad Rotator Web Part]

- Click Add button
• The Ad rotator web part is added to the page
  ◦ Select **Edit Web Part** from the dropdown (on top right) to open the **Ad Rotator Web Part editor**
  ◦ Click on **Select List** button and browse to the existing Advertisement Library
  ◦ Check the option “**Cycle through all images while the viewer is viewing the page.**” (You can choose to show a random image.)
  ◦ The “Fade” transition effect is set by default

19. **Picture Gallery Slideshow Web Part**

Before creating Picture Gallery Slideshow you need to have an existing picture gallery
Creating a Picture Library

- Go to Site Actions > More Options...
- Select Library tab, select Picture Library and name it (e.g. The Earth Palette)

- The newly created picture library appears under Picture Libraries heading in All Site Content

- Upload photos to the picture gallery
- Double click on each photo to open the image properties window
- Add title and description

Creating a Picture Gallery Slideshow

- Go to Site Actions, Edit Page
- Place the cursor at the location you want to insert the Web Part
- Select Editing Tools > Insert > Web Part from the ribbon
• In the Categories, select Media and Content > Picture Library Slideshow Web Part

![Categories and Web Parts](image)

• Click on Add

**Editing Picture Library Slideshow Web Part**

• Select Edit Web Part from the dropdown menu

![Web Part configuration](image)

• Web Part configuration:

  - Duration to Show Picture (seconds)
  
  - 5

  - Picture Library
  
  - The Earth Palette

  - Library View
  
  - All Pictures

  - Picture Display Mode
  
  - Random Order

  - Display with
  
  - Title and Description below image

  - Show Toolbar
20. Creating a Survey

- Go to the site you want to create the survey
- Select Site Actions > More Options...
- In Create page, select Survey

- Another way:
  - Select Site Actions > View All Site content
  - Click on Create icon, and select Survey
• Enter survey name and description, select navigation option, survey options and click OK

Survey Options:

- Check No to "Show user names in survey results" - to keep users anonymous
- Check No to "Allow multiple responses" - users cannot take the survey a second time

• In New Question page:

  - Create your survey question
  - Click Next Question to create more questions
  - Click Finish when all questions are done

• In All Site Content, the new survey appears under the Surveys heading
Survey Setting

In the survey overview page, select Survey Settings under Settings menu.

Under Questions heading,

- you can add a new question
- click on an existing question to edit or delete it

By default, the link to survey takes to the Survey Overview page (overview.aspx).

To go directly to the survey questions, the survey link should point to the NewForm.aspx page.

After a user has completed the survey and click Finish, the Survey Overview page will return automatically.
You can format the survey link to return a thank you page, but it does not work for all browsers.

SharePoint survey was not built for anonymous access. You can enable anonymous access on the list, but there are problems associated with it. A major problem is that you cannot restrict the number of times an anonymous user may complete the survey.

---

21. Calendar

Creating a new calendar:

- Select Site Actions > More Options
  OR
  Site Actions > All Site Content > Create
• Select the Calendar list icon and click on More Options

![Calendar list icon with More Options button]

• Enter the calendar name and description
• Select No to “Display this list on the Quick Launch” (you can add it manually if needed)
• Select No under “Use this calendar to share member’s schedule” if you create an event calendar
• Click Create

**Note:**

If the calendar list does not appear on the Create window, this site does not have Team collaboration Lists activated.

**Activating Team collaboration Lists:**

• **Site Actions > Site Settings**
• Select **Manage Site Features** under Site Actions

![Site Actions menu]

• Activate Team Collaboration Lists

![Team Collaboration Lists]

**Adding a new event**

In All Site Content, the newly created calendar appears under the Lists header.
To add an event to the calendar:

- Click on the calendar list to open it
- Select a date on the calendar
- On the ribbon, select Calendar Tools tab, select Events and click New Event.

Other methods to create a new event:

- Double click on the selected date on the calendar to open the New Item window
- Mouse over the bottom right corner of a date cell and click on + Add

- Enter Title, Location, Start Time, End Time, Description and select a Category

- Leave the following options blank if it is a one-time event with a start and end time

- If it is a repeating event, check Recurrence option "Make this a repeating event"
• Select a recurrence option and specify a pattern

![Recurrence Options]

**Modifying Category list**

• Open calendar
• Select Calendar tab from the ribbon
• Select List Settings
• Scroll down to Columns
• Click on Category link under Columns header
  In Change Column page, modify the category list under Additional Column Settings (edit/remove)
category, or add more category by typing each choice on a separate line)

Calendar views

Switching views using controls on ribbon:

- Select Calendar under Calendar Tools tab
- Month is the default view
  Switch calendar to different views: Day, Week and Month

Switching views on a calendar list page:

- Day view: click on the date number
• **Week view**: click on the left side bar of each week

• Refresh the page to go back to the default **Month view**

---

**Aggregating multiple SharePoint calendars into a single view**

Calendar overlay is a feature in SharePoint that we can use to aggregate information from multiple sources into calendar view. You can add up to 10 overlays to an existing calendar view. Please note that if you connect the calendar to Outlook to synchronize the events, it will only synchronize items from main view and not from the overlays.

1. Create a **master calendar**, e.g. FPA Events

2. Open the master calendar, select the **Events** tab under **Calendar Tools** and click on **Calendars Overlay**
3. Click on New Calendar to add a calendar to the view

4. Provide information about the calendar you want to add.
   - Enter the correct calendar name
   - Select a background color for this calendar to display on the master calendar
   - Web URL: Enter the website address where the calendar is located
   - Click on the Resolve button to populate the List and List view
   - Select the right calendar from the dropdown if there are more than one in that website

• Repeat step 2 and 3 again to add more calendars to the view
Displaying a calendar on a web page

A calendar can be displayed on a web page using Web Part.

- Open the web page in editing mode
- Place the cursor in the page content area
- Select Insert > Web Part (or Insert > Existing List)
• Select the existing calendar list (e.g. FPA Events) under Web Parts column

The overlaid calendars are not populated on the master calendar automatically after it has been inserted to the web page.

To display overlaid calendars in Web Part:

• Select Edit Web Part to open the Web Part Editor.
• Under Selected View, select Calendar from the dropdown list

• Under Appearance, select Chrome Type: None
• Click OK

22. Site Permissions

Each web site created under a parent site should inherit the parent site permissions.
Under Site Actions, select SitePermissions

The status bar shows "This web site inherits permissions from its parents".

Permitted users inherited from parent site:

A website is maintained by its own web owners and contributors. Web owners and contributors of a website only have access permission to their own website and subsites created under their site. They cannot access another website if they are not added to that site permissions.

Note: Only owners of the website with Full Control can manage the site permissions.
Creating unique permissions for a subsite

When a child site needs its unique permissions, it should stop inheriting permissions from its parent. In Site Permissions page, click on "Stop Inheriting Permissions" link on the ribbon.

A message is returned, saying this site now has unique permissions and changes made to the parent site will no longer affect it.

Click OK

Permission inheritance has been stopped, indicated by a checkbox appearing in front of each group name.
Now you can edit the site permission for each user or group, or add new ones.

**Creating a new permission group:**

To create a permission group for a specific website:

1. Open that website
2. From Site Actions, select Site Permissions
3. Click on "Stop Inheriting Permissions" link on the ribbon
4. Click on Create Group

In Create Group page, enter:

- **Group name**
  Naming convention: SiteName Permission
  For example: PayRoll Owners, Research Contributors
  Group name should be **unique**. You will get an error if you enter a group name that already exists.

- **Description** (optional)

- **Group owner** - If you create the group, your username is automatically populated in the Group Owner field, but you can change it to another username or another group name. Click the Check Names icon to verify it.

- **Group Settings** (keep the default: Group Members; Group Owner)

- **Membership Requests** (keep the default: No to both requests)

- **Give Group Permission to this Site**
Check Full Control for site owners group, Contribute for contributors group

Note: When a site has contributors, the content approval workflow for that site should be enabled. Site contributors can edit web pages, create new pages but cannot publish them. Website owners need to approve the page and published it.

Choose the permission level group members get on this site:
http://www.sac.edu/Training/WebUser

- Full Control - Has full control.
- Design - Can view, add, update, delete, approve, and customize.
- Contribute - Can view, add, update, and delete list items and documents.
- Read - Can view pages and list items and download documents.
- Approve - Can edit and approve pages, list items, and documents.
- Manage Hierarchy - Can create sites and edit pages, list items, and documents.
- Restricted Read - Can view pages and documents, but cannot view historical versions or user permissions.
- View Only - Can view pages, list items, and documents. Document types with server-side file handlers can be viewed in the browser but not downloaded.
- Records Center Web Service Submitters - Submit content to this site using Web Services.

When you open a specific website and create a new permission group, but you don’t check any check box to select a permission level, the newly created group has no access to this specific website. However, you can give it access to this website later (see Granting Permissions).

In order to give a group access to a site where it is created, make sure you check a check box to select a permission level before clicking on Create.

Note: Groups are not “owned” by any specific site. No matter where you create permission groups, they belong to the entire Web site. You can add an existing permission group to as many websites as needed.

After creating a new permission group, open Site Permissions page from the Site Actions menu. You will see the newly created permission group appear on the list.

Adding Users to a permission group

Users of a group can access any site the group is added and inherit the same permission assigned to that group (Full Control, Contribute…)

Right after you click on Create, the new group page opens and it is ready for adding users.

- From the Site Actions menu, select Site Permissions and double click on the group name to open the group page.
For example: *WebTraining Owners* with Full Control permission

- Select *Add Users* from the *New* menu

- Enter one username at a time and click on the *check name* icon to validate it.

Sending welcome email to the new users is optional.
New users added to this group will inherit its Full Control permission to this specific site.

- You can also find users by clicking on the browse icon
Enter a search word, click on the search icon, select a correct username, and click Add-

- To remove a user from a group:
  - Click on a check box to select a user
  - Select "Remove Users from Groups" from the Actions menu
Granting permissions to an existing group or a user

A site owner can grant editing permissions to a user or an existing group and assign a permission level for each.

- From Site Actions menu, select Site Permissions
- In Site Permissions page, click on Grant Permissions link on the ribbon

- Enter the group name or username to Users/Groups field and click check name to validate it
- Select “Grant users permissions directly”
- Check a permission level
- Sending welcome email (optional)
- Click OK

The newly added group or user(s) now appear in the **Site Permissions** page. An existing group, or user, can be granted permissions to as many websites as needed.

### Edit / Removing Permissions

Web owner can edit or remove user permissions.

- **To edit permissions:** In **Site Permissions** page, select a username or group name, click on **Edit User Permissions**

![Edit User Permissions](image)

- **To remove permissions:** In **Site Permissions** page, select a username or group name, click on **Remove User Permissions**

![Remove User Permissions](image)

### 23. Anonymous Access

Anonymous access has been enabled by default. When you create a new site, it is recommended to select "Use same permissions as parent site". The newly created site should inherit anonymous access as well as all permission groups from its parent.

In **Site Permissions** page, **Anonymous Users’** permission is listed on top of other permitted users’ groups.
You can make a subsite internal by disabling Anonymous Access for that site.

To disable/enable Anonymous Access to a subsite, that specific site should have unique permissions.

- From Site Actions menu, select Site Permissions
- If this site still inherit parent permissions, click on Stop Inheriting Parent Permissions
- The Anonymous Access link only appears when the site has unique permissions
- Click on Anonymous Access link
- Select "Nothing" to disable it
- You can enable Anonymous Access later by selecting "Entire Web site"
24. Document Sharing

Text here

25. Team Site Admin

Text here